CSR code samples #11 (Fully customized forms with CSRListForm)

This Client side rendering code sample will help you to work with CSRListForm and build your sharepoint list forms form scratch and use any form layout and design that you want. Note: This sample is part from series of samples to learn you how to work with CSR templates. How t

 
 
 
 
 
3.7 Star
(6)
1,849 times
Add to favorites
3/19/2015
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • PreSaveAction and PreSaveItem don't trigger with this method
    1 Posts | Last post February 09, 2019
    • I have implemented your code successfully and can save a form using your method.  But when I do this the PreSaveAction and PreSaveItem functions don't fire off.
      
      It's probably because we're not using the standard Save function.
      
      Any ideas on how to get those 2 to work?
      
      Thank you
  • Nice :))
    1 Posts | Last post February 14, 2018
  • About save
    1 Posts | Last post July 26, 2017
    • hi,
      It's a good job. so I do the same example, I get the result, but my problem when I want to to modify so I open the list I can see and after when I click modify no thing is affected.
      So i didn't know the problem , hope u can help me thinks
      Sorry for my English 
      Cordialy nadia 
  • Attachment control is not working.
    3 Posts | Last post June 19, 2017
    • Hi,
      
      I have followed your approach to create a NewItem form . It is working as expected when I do not have any attachment added. 
      
      But when select attach file from the ribbon and click on OK button, I am getting error as `Cannot read property 'insertRow' of null at OkAttach`. 
      
      Can you please suggest me the workaround for this error. 
      
      Thanks,
      Rohit
    • somehow I managed to find the solution. 
      
      Refer this link --> https://sharepoint.stackexchange.com/questions/218197/sharepoint-csr-attachment-control-on-newform-aspx
    • Upon setting the webpart to use CSRListForm no attachment elements are rendered ('csrAttachmentUploadDiv' and 'idAttachmentsRow' are missing), nor does the outer 'part1' span exist. Anything you also encountered? Did you manually add the attachment elements to the template? 
  • Attachment Issue
    2 Posts | Last post June 14, 2017
    • After customizing the page, attachment is not working. 
      Do you have any workaround or fix for this issue, it is very important functionality.
    • @Senthildevarajan I am facing the same issue with the attachment control. If you have found any workaround for this issue, can you please guide me. 
  • Override method is not called
    1 Posts | Last post October 19, 2016
    • Hi,
      
      I am trying to customize list new form (Referring this article). Bit as per the code given, viewTemplate is not getting called. Also ctx throwing error as "undefined".
      
      Could you please clarify it?
      
      Thanks,
      Ravi
  • List with version history & jslink
    1 Posts | Last post October 17, 2016
    • How can I get multi line text field's different versions to render when "Append Changes to Existing Text" is set on.
  • save / edit buttons
    2 Posts | Last post June 13, 2016
    • the save and edit buttons in the ribbon are disabled! Is there any fix?
    • I haven't been able to see a solution for this, so I created a forum question:
      
      https://social.msdn.microsoft.com/Forums/en-US/f9f4dd86-4803-4f45-a225-b7cdd993c56e/jslink-csrlistform-template-type-disables-ribbon-save-cancel-buttons?forum=appsforsharepoint
  • CSR JSLink Form not saving
    1 Posts | Last post May 05, 2016
    • How to find that why CSR JSlink form is not saving. There are some required fields or validation that cause the form not saving????
  • taxonomy field problem
    4 Posts | Last post February 05, 2016
    • Why is only one taxonomy field rendering when you apply "CSRListForm"? It doesn´t happen if you apply only "ListForm" template, but then you can not get this work.
    • I am having the same problem and trying to find a solution. If I do I will let you know and hope you'll do the same ;)
      It looks like a bug...
    • I found a solution. Look here to see the alterations on the code: https://gist.github.com/sduschinger/0065535dc193bf6aca5d/revisions
      
      This was quite some work to find out ;)
      
      
      
      
    • thank you very much!
1 - 10 of 17 Items