Hilo (updated for Visual Studio 2013)

“Hilo” is a series of articles and sample applications that demonstrate how you can leverage the power of Windows 7, Visual Studio 2010 and Visual C++ to build high performance, rich responsive client applications.

C++ (16.5 MB)
 
 
 
 
 
4.8 Star
(24)
74,617 times
Add to favorites
10/9/2014
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • 555-555-0199@example.com
    1 Posts | Last post October 12, 2017
    • 555-555-0199@example.com
  • Getting Error in Hilo project
    2 Posts | Last post July 28, 2015
    • Error	1	error MSB6006: "cmd.exe" exited with code -1073741511.	E:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppCommon.targets	170	5	Annotator
      
    • When I built it today I had the same issue.  Modifying the annotator project VC++ directories for executable directories to point to my 7.1A SDK install alleviated the issue.
      (C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\Bin;$(ExecutablePath))
  • Remove .sdf file from archive!
    1 Posts | Last post October 10, 2014
    • 16.5 MB archive, which contains 1 MB of code and 55 mb .sdf (intellisense generated file).
      
      OMG, remove it and archive will be 800kb.
  • Getting Error in Hilo project
    1 Posts | Last post August 25, 2013
    • I Installed visual studio2010 express then i installed windows 7 SDK.when i build hilo project i am getting following error 2 times  and grting build result as 2 succeds 2 failed. anyone can help me???
      
      >C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets(151,5): error MSB6006: "cmd.exe" exited with code 9009
  • no file: Flickr.wsdl.h
    1 Posts | Last post August 27, 2012
    • I found in the latest Hilo source code (Updated 4/18/2011),  no file of Flickr.wsdl.h was included in the project. Should this file be generated by our own or it's just missing to be included?
  • Problem solved
    1 Posts | Last post May 18, 2012
    • FYI for others.  If you have Win7 x64, do not accept the default path for the SDK 7.1 installer. It uses the "Program Files" directory.  You must install the SDK to Program Files (x86)\Microsoft SDKs\Windows\v7.1  Finally, there are 4 projects within the Hilo solution.  Change the Platform Toolset to SDK 7.1 ONLY for the Browser and Annotator projects.  The Platform Toolset for the Common and Registration Helper projects MUST remain pointed to v100.
      The Hilo solution compiles and runs.  It's beautiful.  Can't wait to start learning from it. 
      Microsoft should "fix" the SDK installer to detect x64 systems and set the default installation path accordingly.  Instructions about how to change the Platform Toolset also need to be included on this page.
  • P.S.
    1 Posts | Last post May 14, 2012
  • Missing wsutil
    1 Posts | Last post May 14, 2012
    • I installed Visual C++ Express, then I installed Windows SDK v7.0, then I downloaded and unpacked the Hilo project.  When I attempt to build it I receive an error message essentially stating that wsutil was not found and the build fails. I attempted to run wsutil from the SDK command prompt and I receive a similar message, wsutil doesn't exist. I attempted to run setenv from the SDK command prompt and was informed that VC++ is using SKD 7.0xxx. I searched for wsutil from the Windows search box and it also comes up empty. I am using Win7 Home Premium x64.
      Can anyone help me?  I'd really like to get the Hilo project running. 
      Thank you.
      
      Mike
  • How to use Hilo With XP SP3
    1 Posts | Last post January 11, 2012
    • I have platform setup Windows XP SP3 and visual studio 2010 professional. I want to use Hilo project with this as Hilo using Direct2D which doesn't support XP. Can any one suggest how should i run Hilo with XP(it giving me error d2d1.dll not found). I can not change for Vista or Windows 7 because of available device drivers limitation with my project.
  • Error
    4 Posts | Last post October 18, 2011
    • there is an you error when i'm trying to run it it shows: "cmd.exe" exited with code 9009 
      what should i do to run the program ?
    • Hi,
      
      Did you try running it as an Administrator?
      Or the files may be corrupt.
      
      Try to download and install again.
    • Hey,
      
      Try to open Properties for Annotator (right click) and select Configuration Properties --> General. Then set Platform Toolset to "Windows7.1SDK" (need to install Windows SDK 7.1 first).
      
      Good Luck
    • That's right.  It looks like a problem with running a command during build.
      
1 - 10 of 11 Items